What’s Vulnerable › Vulnerabilities
CVE-2021-20206
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-26 · updated 2026-06-17
- Weakness: CWE-20
Description
An improper limitation of path name flaw was found in containernetworking/cni in versions before 0.8.1. When specifying the plugin to load in the 'type' field in the network configuration, it is possible to use special elements such as "../" separators to reference binaries elsewhere on the system. This flaw allows an attacker to execute other existing binaries other than the cni plugins/types, such as 'reboot'. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Affected products
- Linuxfoundation Container Network Interface: before 0.8.1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: Linuxfoundation Container Network Interface 0.8.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1919391
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMCONTAINERNETWORKINGCNIPKGINVOKE-1070549
- https://bugzilla.redhat.com/show_bug.cgi?id=1919391
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMCONTAINERNETWORKINGCNIPKGINVOKE-1070549
Get alerted when CVE-2021-20206 or the next vulnerability affects your stack