What’s Vulnerable › Vulnerabilities
CVE-2021-20211
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-401
Description
A flaw was found in Privoxy in versions before 3.0.29. Memory leak when client tags are active can cause a system crash.
Affected products
- privoxy: before 3.0.29 — fixed in 3.0.29
How to fix
Upgrade to a fixed version: privoxy 3.0.29. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1928733
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/3.0.29/user-manual/whatsnew.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1928733
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/3.0.29/user-manual/whatsnew.html
Get alerted when CVE-2021-20211 or the next vulnerability affects your stack