What’s Vulnerable › Vulnerabilities
CVE-2021-20216
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-400
Description
A flaw was found in Privoxy in versions before 3.0.31. A memory leak that occurs when decompression fails unexpectedly may lead to a denial of service. The highest threat from this vulnerability is to system availability.
Affected products
- privoxy: before 3.0.31 — fixed in 3.0.31
How to fix
Upgrade to a fixed version: privoxy 3.0.31. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1923256
- https://security.gentoo.org/glsa/202107-16
- https://www.openwall.com/lists/oss-security/2021/01/31/2
- https://www.privoxy.org/3.0.31/user-manual/whatsnew.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1923256
- https://security.gentoo.org/glsa/202107-16
- https://www.openwall.com/lists/oss-security/2021/01/31/2
- https://www.privoxy.org/3.0.31/user-manual/whatsnew.html
Get alerted when CVE-2021-20216 or the next vulnerability affects your stack