What’s Vulnerable › Vulnerabilities
CVE-2021-20217
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-617
Description
A flaw was found in Privoxy in versions before 3.0.31. An assertion failure triggered by a crafted CGI request may lead to denial of service. The highest threat from this vulnerability is to system availability.
Affected products
- privoxy: before 3.0.31 — fixed in 3.0.31
How to fix
Upgrade to a fixed version: privoxy 3.0.31. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1923252
- https://security.gentoo.org/glsa/202107-16
- https://bugzilla.redhat.com/show_bug.cgi?id=1923252
- https://security.gentoo.org/glsa/202107-16
Get alerted when CVE-2021-20217 or the next vulnerability affects your stack