What’s Vulnerable › Vulnerabilities
CVE-2021-20219
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-697
Description
A denial of service vulnerability was found in n_tty_receive_char_special in drivers/tty/n_tty.c of the Linux kernel. In this flaw a local attacker with a normal user privilege could delay the loop (due to a changing ldata->read_head, and a missing sanity check) and cause a threat to the system availability.
Affected products
- Linux kernel: before 4.18 — fixed in 4.18
How to fix
Upgrade to a fixed version: Linux kernel 4.18. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1923738
- https://bugzilla.redhat.com/show_bug.cgi?id=1923738
Get alerted when CVE-2021-20219 or the next vulnerability affects your stack