What’s Vulnerable › Vulnerabilities
CVE-2021-20225
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-787
Description
A flaw was found in grub2 in versions prior to 2.06. The option parser allows an attacker to write past the end of a heap-allocated buffer by calling certain commands with a large number of specific short forms of options. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Fedoraproject Fedora: 33, 34
- grub2: before 2.06 — fixed in 2.06
- NetApp ONTAP Select Deploy administration utility: all versions
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Enterprise Linux Server Aus: 7.2, 7.3, 7.4, 7.6, 7.7, 8.2
- RedHat Enterprise Linux Server Eus: 7.6, 7.7, 8.1
- RedHat Enterprise Linux Server Tus: 7.4, 7.6, 7.7, 8.2
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: grub2 2.06. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1924696
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZWZ36QK4IKU6MWDWNOOWKPH3WXZBHT2R/
- https://security.gentoo.org/glsa/202104-05
- https://security.netapp.com/advisory/ntap-20220325-0001/
- https://bugzilla.redhat.com/show_bug.cgi?id=1924696
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZWZ36QK4IKU6MWDWNOOWKPH3WXZBHT2R/
- https://security.gentoo.org/glsa/202104-05
- https://security.netapp.com/advisory/ntap-20220325-0001/
Get alerted when CVE-2021-20225 or the next vulnerability affects your stack