What’s Vulnerable › Vulnerabilities
CVE-2021-20229
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-23 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in PostgreSQL in versions before 13.2. This flaw allows a user with SELECT privilege on one column to craft a special query that returns all columns of the table. The highest threat from this vulnerability is to confidentiality.
Affected products
- Fedoraproject Fedora: 33
- PostgreSQL: from 13.0 before 13.2 — fixed in 13.2
- Red Hat Enterprise Linux: 7.0, 8.0
- RedHat Software Collections: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 13.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1925296
- https://security.gentoo.org/glsa/202105-32
- https://security.netapp.com/advisory/ntap-20210326-0005/
- https://bugzilla.redhat.com/show_bug.cgi?id=1925296
- https://security.gentoo.org/glsa/202105-32
- https://security.netapp.com/advisory/ntap-20210326-0005/
Get alerted when CVE-2021-20229 or the next vulnerability affects your stack