What’s Vulnerable › Vulnerabilities
CVE-2021-20235
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 43.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-01 · updated 2026-06-17
- Weakness: CWE-120
Description
There's a flaw in the zeromq server in versions before 4.3.3 in src/decoder_allocators.hpp. The decoder static allocator could have its sized changed, but the buffer would remain the same as it is a static buffer. A remote, unauthenticated attacker who sends a crafted request to the zeromq server could trigger a buffer overflow WRITE of arbitrary data if CURVE/ZAP authentication is not enabled. The greatest impact of this flaw is to application availability, data integrity, and confidentiality.
Affected products
- zeromq libzmq: from 4.2.0 before 4.3.3 — fixed in 4.3.3
How to fix
Upgrade to a fixed version: zeromq libzmq 4.3.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1921983
- https://github.com/zeromq/libzmq/security/advisories/GHSA-fc3w-qxf5-7hp6
- https://bugzilla.redhat.com/show_bug.cgi?id=1921983
- https://github.com/zeromq/libzmq/security/advisories/GHSA-fc3w-qxf5-7hp6
Get alerted when CVE-2021-20235 or the next vulnerability affects your stack