What’s Vulnerable › Vulnerabilities
CVE-2021-20237
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-28 · updated 2026-06-17
- Weakness: CWE-400
Description
An uncontrolled resource consumption (memory leak) flaw was found in ZeroMQ's src/xpub.cpp in versions before 4.3.3. This flaw allows a remote unauthenticated attacker to send crafted PUB messages that consume excessive memory if the CURVE/ZAP authentication is disabled on the server, causing a denial of service. The highest threat from this vulnerability is to system availability.
Affected products
- zeromq libzmq: from 4.2.0 before 4.3.3 — fixed in 4.3.3
How to fix
Upgrade to a fixed version: zeromq libzmq 4.3.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1921989
- https://github.com/zeromq/libzmq/security/advisories/GHSA-4p5v-h92w-6wxw
- https://bugzilla.redhat.com/show_bug.cgi?id=1921989
- https://github.com/zeromq/libzmq/security/advisories/GHSA-4p5v-h92w-6wxw
Get alerted when CVE-2021-20237 or the next vulnerability affects your stack