What’s Vulnerable › Vulnerabilities
CVE-2021-20251
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-362
Description
A flaw was found in samba. A race condition in the password lockout code may lead to the risk of brute force attacks being successful if special conditions are met.
Affected products
- Fedoraproject Fedora: 37
- Samba: from 4.1.0 before 4.16.8; from 4.17.0 before 4.17.4 — fixed in 4.16.8, 4.17.4
How to fix
Upgrade to a fixed version: Samba 4.16.8, 4.17.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1929800
- https://bugzilla.samba.org/show_bug.cgi?id=14611
- https://security.gentoo.org/glsa/202309-06
- https://security.netapp.com/advisory/ntap-20230331-0005/
- https://bugzilla.redhat.com/show_bug.cgi?id=1929800
- https://bugzilla.samba.org/show_bug.cgi?id=14611
- https://security.gentoo.org/glsa/202309-06
- https://security.netapp.com/advisory/ntap-20230331-0005/
Get alerted when CVE-2021-20251 or the next vulnerability affects your stack