What’s Vulnerable › Vulnerabilities
CVE-2021-20253
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-09 · updated 2026-06-17
- Weakness: CWE-552
Description
A flaw was found in ansible-tower. The default installation is vulnerable to Job Isolation escape allowing an attacker to elevate the privilege from a low privileged user to the awx user from outside the isolated environment. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Tower: before 3.6.7; from 3.7.0 before 3.7.5; from 3.8.0 before 3.8.2 — fixed in 3.6.7, 3.7.5, 3.8.2
How to fix
Upgrade to a fixed version: Tower 3.6.7, 3.7.5, 3.8.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1928847
- https://bugzilla.redhat.com/show_bug.cgi?id=1928847
Get alerted when CVE-2021-20253 or the next vulnerability affects your stack