What’s Vulnerable › Vulnerabilities
CVE-2021-20259
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-07 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in the Foreman project. The Proxmox compute resource exposes the password through the API to an authenticated local attacker with view_hosts permission. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. Versions before foreman_fog_proxmox 0.13.1 are affected
Affected products
- theforeman Foremanfogproxmox: before 0.13.1 — fixed in 0.13.1
How to fix
Upgrade to a fixed version: theforeman Foremanfogproxmox 0.13.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1932144
- https://bugzilla.redhat.com/show_bug.cgi?id=1932144
Get alerted when CVE-2021-20259 or the next vulnerability affects your stack