What’s Vulnerable › Vulnerabilities
CVE-2021-20261
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-11 · updated 2026-06-17
- Weakness: CWE-362
Description
A race condition was found in the Linux kernels implementation of the floppy disk drive controller driver software. The impact of this issue is lessened by the fact that the default permissions on the floppy device (/dev/fd0) are restricted to root. If the permissions on the device have changed the impact changes greatly. In the default configuration root (or equivalent) permissions are required to attack this flaw.
Affected products
- Linux kernel: before 4.5; 4.5, 4.5-rc1, 4.5-rc2, 4.5-rc3, 4.5-rc4 — fixed in 4.5
- Red Hat Enterprise Linux: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 4.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1932150
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=a0c80efe5956ccce9fe7ae5c78542578c07bc20a
- https://bugzilla.redhat.com/show_bug.cgi?id=1932150
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=a0c80efe5956ccce9fe7ae5c78542578c07bc20a
Get alerted when CVE-2021-20261 or the next vulnerability affects your stack