What’s Vulnerable › Vulnerabilities
CVE-2021-20268
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-09 · updated 2026-06-17
- Weakness: CWE-20
Description
An out-of-bounds access flaw was found in the Linux kernel's implementation of the eBPF code verifier in the way a user running the eBPF script calls dev_map_init_map or sock_map_alloc. This flaw allows a local user to crash the system or possibly escalate their privileges. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Affected products
- Linux kernel: before 5.10.10 — fixed in 5.10.10
How to fix
Upgrade to a fixed version: Linux kernel 5.10.10. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1923816
- https://lore.kernel.org/bpf/CACAyw99bEYWJCSGqfLiJ9Jp5YE1ZsZSiJxb4RFUTwbofipf0dA%40mail.gmail.com/T/#m8929643e99bea9c18ed490a7bc2591145eac6444
- https://security.netapp.com/advisory/ntap-20210409-0006/
- https://bugzilla.redhat.com/show_bug.cgi?id=1923816
- https://lore.kernel.org/bpf/CACAyw99bEYWJCSGqfLiJ9Jp5YE1ZsZSiJxb4RFUTwbofipf0dA%40mail.gmail.com/T/#m8929643e99bea9c18ed490a7bc2591145eac6444
- https://security.netapp.com/advisory/ntap-20210409-0006/
Get alerted when CVE-2021-20268 or the next vulnerability affects your stack