What’s Vulnerable › Vulnerabilities
CVE-2021-20272
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-09 · updated 2026-06-17
- Weakness: CWE-617
Description
A flaw was found in privoxy before 3.0.32. An assertion failure could be triggered with a crafted CGI request leading to server crash.
Affected products
- Debian Linux: 9.0
- privoxy: before 3.0.32 — fixed in 3.0.32
How to fix
Upgrade to a fixed version: privoxy 3.0.32. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1936651
- https://lists.debian.org/debian-lts-announce/2021/03/msg00009.html
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/announce.txt
- https://bugzilla.redhat.com/show_bug.cgi?id=1936651
- https://lists.debian.org/debian-lts-announce/2021/03/msg00009.html
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/announce.txt
Get alerted when CVE-2021-20272 or the next vulnerability affects your stack