What’s Vulnerable › Vulnerabilities
CVE-2021-20274
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-09 · updated 2026-06-17
- Weakness: CWE-476
Description
A flaw was found in privoxy before 3.0.32. A crash may occur due a NULL-pointer dereference when the socks server misbehaves.
Affected products
- privoxy: before 3.0.32 — fixed in 3.0.32
How to fix
Upgrade to a fixed version: privoxy 3.0.32. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1936662
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/announce.txt
- https://bugzilla.redhat.com/show_bug.cgi?id=1936662
- https://security.gentoo.org/glsa/202107-16
- https://www.privoxy.org/announce.txt
Get alerted when CVE-2021-20274 or the next vulnerability affects your stack