What’s Vulnerable › Vulnerabilities

CVE-2021-20283

Description

The web service responsible for fetching other users' enrolled courses did not validate that the requesting user had permission to view that information in each course in moodle before 3.10.2, 3.9.5, 3.8.8, 3.5.17.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.10.2, 3.5.17, 3.8.8, 3.9.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-20283 or the next vulnerability affects your stack