What’s Vulnerable › Vulnerabilities
CVE-2021-20286
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-15 · updated 2026-06-17
- Weakness: CWE-617
Description
A flaw was found in libnbd 1.7.3. An assertion failure in nbd_unlocked_opt_go in ilb/opt.c may lead to denial of service.
Affected products
- Red Hat Enterprise Linux: 8.3.0
- [UNKNOWN] libnbd: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: [UNKNOWN] libnbd 1.7.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1934727
- https://gitlab.com/nbdkit/libnbd/-/commit/fb4440de9cc76e9c14bd3ddf3333e78621f40ad0
- https://bugzilla.redhat.com/show_bug.cgi?id=1934727
- https://gitlab.com/nbdkit/libnbd/-/commit/fb4440de9cc76e9c14bd3ddf3333e78621f40ad0
Get alerted when CVE-2021-20286 or the next vulnerability affects your stack