What’s Vulnerable › Vulnerabilities
CVE-2021-20290
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-863
Description
An improper authorization handling flaw was found in Foreman. The OpenSCAP plugin for the smart-proxy allows foreman clients to execute actions that should be limited to the Foreman Server. This flaw allows an authenticated local attacker to access and delete limited resources and also causes a denial of service on the Foreman server. The highest threat from this vulnerability is to integrity and system availability.
Affected products
- smart_proxy_openscap: before 0.9.1 — fixed in 0.9.1
How to fix
Upgrade to a fixed version: smart_proxy_openscap 0.9.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1939701
- https://bugzilla.redhat.com/show_bug.cgi?id=1939701
Get alerted when CVE-2021-20290 or the next vulnerability affects your stack