What’s Vulnerable › Vulnerabilities
CVE-2021-20296
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-01 · updated 2026-06-17
- Weakness: CWE-476
Description
A flaw was found in OpenEXR in versions before 3.0.0-beta. A crafted input file supplied by an attacker, that is processed by the Dwa decompression functionality of OpenEXR's IlmImf library, could cause a NULL pointer dereference. The highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 9.0, 10.0
- AcademySoftwareFoundation openexr: before 2.4.3; from 2.5.0 before 2.5.4 — fixed in 2.4.3, 2.5.4
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 2.4.3, 2.5.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=24854
- https://bugzilla.redhat.com/show_bug.cgi?id=1939141
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202107-27
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=24854
- https://bugzilla.redhat.com/show_bug.cgi?id=1939141
- https://lists.debian.org/debian-lts-announce/2021/07/msg00001.html
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202107-27
Get alerted when CVE-2021-20296 or the next vulnerability affects your stack