What’s Vulnerable › Vulnerabilities
CVE-2021-20299
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-16 · updated 2026-06-17
- Weakness: CWE-476
Description
A flaw was found in OpenEXR's Multipart input file functionality. A crafted multi-part input file with no actual parts can trigger a NULL pointer dereference. The highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 10.0
- AcademySoftwareFoundation openexr: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 2.5.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25740
- https://bugzilla.redhat.com/show_bug.cgi?id=1939154
- https://github.com/AcademySoftwareFoundation/openexr/commit/25e9515b06a6bc293d871622b8cafaee7af84e0f
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25740
- https://bugzilla.redhat.com/show_bug.cgi?id=1939154
- https://github.com/AcademySoftwareFoundation/openexr/commit/25e9515b06a6bc293d871622b8cafaee7af84e0f
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
Get alerted when CVE-2021-20299 or the next vulnerability affects your stack