What’s Vulnerable › Vulnerabilities
CVE-2021-20300
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-04 · updated 2026-06-17
- Weakness: CWE-190
Description
A flaw was found in OpenEXR's hufUncompress functionality in OpenEXR/IlmImf/ImfHuf.cpp. This flaw allows an attacker who can submit a crafted file that is processed by OpenEXR, to trigger an integer overflow. The highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 10.0
- AcademySoftwareFoundation openexr: before 2.5.4 — fixed in 2.5.4
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 2.5.4. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25562
- https://bugzilla.redhat.com/show_bug.cgi?id=1939153
- https://github.com/AcademySoftwareFoundation/openexr/pull/836
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25562
- https://bugzilla.redhat.com/show_bug.cgi?id=1939153
- https://github.com/AcademySoftwareFoundation/openexr/pull/836
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
Get alerted when CVE-2021-20300 or the next vulnerability affects your stack