What’s Vulnerable › Vulnerabilities
CVE-2021-20305
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-05 · updated 2026-10-14
- Weakness: CWE-327
Description
A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 33
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp ONTAP Select Deploy administration utility: all versions
- [UNKNOWN] nettle: before 3.7.2 — fixed in 3.7.2
- Red Hat Enterprise Linux: 7.0, 8.0
How to fix
Upgrade to a fixed version: [UNKNOWN] nettle 3.7.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1942533
- https://lists.debian.org/debian-lts-announce/2021/09/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MQKWVVMAIDAJ7YAA3VVO32BHLDOH2E63/
- https://security.gentoo.org/glsa/202105-31
- https://security.netapp.com/advisory/ntap-20211022-0002/
- https://www.debian.org/security/2021/dsa-4933
- https://bugzilla.redhat.com/show_bug.cgi?id=1942533
- https://lists.debian.org/debian-lts-announce/2021/09/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MQKWVVMAIDAJ7YAA3VVO32BHLDOH2E63/
- https://security.gentoo.org/glsa/202105-31
- https://security.netapp.com/advisory/ntap-20211022-0002/
- https://www.debian.org/security/2021/dsa-4933
Get alerted when CVE-2021-20305 or the next vulnerability affects your stack