What’s Vulnerable › Vulnerabilities
CVE-2021-20313
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-11 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in ImageMagick in versions before 7.0.11. A potential cipher leak when the calculate signatures in TransformSignature is possible. The highest threat from this vulnerability is to data confidentiality.
Affected products
- Debian Linux: 9.0
- ImageMagick: before 7.0.11-0 — fixed in 7.0.11-0
How to fix
Upgrade to a fixed version: ImageMagick 7.0.11-0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1947019
- https://lists.debian.org/debian-lts-announce/2021/06/msg00000.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00020.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1947019
- https://lists.debian.org/debian-lts-announce/2021/06/msg00000.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00020.html
Get alerted when CVE-2021-20313 or the next vulnerability affects your stack