What’s Vulnerable › Vulnerabilities
CVE-2021-20315
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-667
Description
A locking protection bypass flaw was found in some versions of gnome-shell as shipped within CentOS Stream 8, when the "Application menu" or "Window list" GNOME extensions are enabled. This flaw allows a physical attacker who has access to a locked system to kill existing applications and start new ones as the locked user, even if the session is still locked.
Affected products
- Centos Stream: 8
- gnome-shell: before 3.32.2 — fixed in 3.32.2
How to fix
Upgrade to a fixed version: gnome-shell 3.32.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2006285
- https://bugzilla.redhat.com/show_bug.cgi?id=2006285
Get alerted when CVE-2021-20315 or the next vulnerability affects your stack