What’s Vulnerable › Vulnerabilities
CVE-2021-20326: Specially crafted query may result in a denial of service of mongod
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-30 · updated 2026-06-17
- Weakness: CWE-20
Description
A user authorized to performing a specific type of find query may trigger a denial of service. This issue affects MongoDB Server v4.4 versions prior to 4.4.4.
Affected products
- MongoDB: from 4.4.0 before 4.4.4 — fixed in 4.4.4
How to fix
Upgrade to a fixed version: MongoDB 4.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-20326 or the next vulnerability affects your stack