What’s Vulnerable › Vulnerabilities
CVE-2021-20330: Specific replication command with malformed oplog entries can crash secondaries
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-15 · updated 2026-06-17
- Weakness: CWE-20
Description
An attacker with basic CRUD permissions on a replicated collection can run the applyOps command with specially malformed oplog entries, resulting in a potential denial of service on secondaries. This issue affects MongoDB Server v4.0 versions prior to 4.0.27; MongoDB Server v4.2 versions prior to 4.2.16; MongoDB Server v4.4 versions prior to 4.4.9.
Affected products
- MongoDB: from 4.0.0 before 4.0.25; from 4.2.0 before 4.2.14; from 4.4.0 before 4.4.6 — fixed in 4.0.25, 4.2.14, 4.4.6
How to fix
Upgrade to a fixed version: MongoDB 4.0.25, 4.2.14, 4.4.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-20330 or the next vulnerability affects your stack