What’s Vulnerable › Vulnerabilities
CVE-2021-20334: Local privilege escalation in MongoDB Compass for Windows
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-06 · updated 2026-06-17
- Weakness: CWE-269
Description
A malicious 3rd party with local access to the Windows machine where MongoDB Compass is installed can execute arbitrary software with the privileges of the user who is running MongoDB Compass. This issue affects: MongoDB Inc. MongoDB Compass 1.x version 1.3.0 on Windows and later versions; 1.x versions prior to 1.25.0 on Windows.
Affected products
- MongoDB Compass: from 1.3.0 before 1.25.0 — fixed in 1.25.0
How to fix
Upgrade to a fixed version: MongoDB Compass 1.25.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-20334 or the next vulnerability affects your stack