What’s Vulnerable › Vulnerabilities
CVE-2021-20392
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM QRadar User Behavior Analytics 1.0.0 through 4.0.1 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.
Affected products
- IBM QRadar User Behavior Analytics: from 1.0.0 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: IBM QRadar User Behavior Analytics 4.1.0. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/196000
- https://www.ibm.com/support/pages/node/6453105
- https://exchange.xforce.ibmcloud.com/vulnerabilities/196000
- https://www.ibm.com/support/pages/node/6453105
Get alerted when CVE-2021-20392 or the next vulnerability affects your stack