What’s Vulnerable › Vulnerabilities
CVE-2021-20470
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-03 · updated 2026-06-17
- Weakness: CWE-521
Description
IBM Cognos Analytics 11.1.7 and 11.2.0 does not require that users should have strong passwords by default, which makes it easier for attackers to compromise user accounts. IBM X-Force ID: 196339.
Affected products
- IBM Cognos Analytics: from 11.1.0 before 11.1.7; 11.1.7, 11.1.7-fixpack1, 11.1.7-fixpack2, 11.1.7-fixpack3, 11.2.0 — fixed in 11.1.7
- OnCommand Insight: all versions
How to fix
Upgrade to a fixed version: IBM Cognos Analytics 11.1.7. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/196939
- https://security.netapp.com/advisory/ntap-20211223-0006/
- https://www.ibm.com/support/pages/node/6520510
- https://exchange.xforce.ibmcloud.com/vulnerabilities/196939
- https://security.netapp.com/advisory/ntap-20211223-0006/
- https://www.ibm.com/support/pages/node/6520510
Get alerted when CVE-2021-20470 or the next vulnerability affects your stack