What’s Vulnerable › Vulnerabilities
CVE-2021-20491
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-16 · updated 2026-06-17
- Weakness: CWE-787
Description
IBM Spectrum Protect Server 7.1 and 8.1 is subject to a stack-based buffer overflow caused by improper bounds checking during the parsing of commands. By issuing such a command with an improper parameter, an authorized administrator could overflow a buffer and cause the server to crash. IBM X-Force ID: 197792.
Affected products
- IBM Spectrum Protect: from 7.1.0.000 before 7.1.13; from 8.1.0.000 through 8.1.10.100; 8.1.11.000 — fixed in 7.1.13
How to fix
Upgrade to a fixed version: IBM Spectrum Protect 7.1.13. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/197792
- https://www.ibm.com/support/pages/node/6442993
- https://exchange.xforce.ibmcloud.com/vulnerabilities/197792
- https://www.ibm.com/support/pages/node/6442993
Get alerted when CVE-2021-20491 or the next vulnerability affects your stack