What’s Vulnerable › Vulnerabilities
CVE-2021-20517
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
IBM WebSphere Application Server Network Deployment 8.5 and 9.0 could allow a remote authenticated attacker to traverse directories. An attacker could send a specially-crafted URL request containing "dot dot" sequences (/../) to read and delete arbitrary files on the system. IBM X-Force ID: 198435.
Affected products
- IBM WebSphere Application Server ND: from 8.5.0.0 before 8.5.5.20; from 9.0.0.0 before 9.0.5.8 — fixed in 8.5.5.20, 9.0.5.8
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server ND 8.5.5.20, 9.0.5.8. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/198435
- https://www.ibm.com/support/pages/node/6456955
- https://exchange.xforce.ibmcloud.com/vulnerabilities/198435
- https://www.ibm.com/support/pages/node/6456955
Get alerted when CVE-2021-20517 or the next vulnerability affects your stack