What’s Vulnerable › Vulnerabilities
CVE-2021-20751
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
Affected products
- EC-CUBE CO.,LTD. EC-CUBE: from 4.0.0 before 4.0.5; 4.0.5. — fixed in 4.0.5
How to fix
Upgrade to a fixed version: EC-CUBE CO.,LTD. EC-CUBE 4.0.5. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN95292458/index.html
- https://www.ec-cube.net/info/weakness/weakness.php?id=78
- https://jvn.jp/en/jp/JVN95292458/index.html
- https://www.ec-cube.net/info/weakness/weakness.php?id=78
Get alerted when CVE-2021-20751 or the next vulnerability affects your stack