What’s Vulnerable › Vulnerabilities
CVE-2021-20784
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-14 · updated 2026-06-17
- Weakness: CWE-644
Description
HTTP header injection vulnerability in Everything version 1.0, 1.1, and 1.2 except the Lite version may allow a remote attacker to inject an arbitrary script or alter the website that uses the product.
Affected products
- voidtools Everything: before 1.1; from 1.1 before 1.2; from 1.2 before 1.3 — fixed in 1.1, 1.2, 1.3
How to fix
Upgrade to a fixed version: voidtools Everything 1.1, 1.2, 1.3. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN68971465/
- https://www.voidtools.com/
- https://www.voidtools.com/downloads/
- https://jvn.jp/en/jp/JVN68971465/index.html
- https://www.voidtools.com/
- https://www.voidtools.com/downloads/
Get alerted when CVE-2021-20784 or the next vulnerability affects your stack