What’s Vulnerable › Vulnerabilities
CVE-2021-20987: Hilscher: EtherNet/IP stack crash for specific CIP service
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-16 · updated 2026-06-17
- Weakness: CWE-787
Description
A denial of service and memory corruption vulnerability was found in Hilscher EtherNet/IP Core V2 prior to V2.13.0.21that may lead to code injection through network or make devices crash without recovery.
Affected products
- Hilscher Ethernet/Ip Adapter Firmware: from 2.0 before 2.13.0.21 — fixed in 2.13.0.21
- Pepperl-Fuchs Pcv100-F200-B25-V1D-6011-6720 Firmware: through 1.10.0
- Pepperl-Fuchs Pcv100-F200-B25-V1D-6011 Firmware: through 1.10.0
- Pepperl-Fuchs Pcv50-F200-B25-V1D Firmware: through 1.10.0
- Pepperl-Fuchs Pcv80-F200-B25-V1D Firmware: through 1.10.0
- Pepperl-Fuchs Pxv100-F200-B25-V1D Firmware: through 1.10.0
- Pepperl-Fuchs Pxv100I-F200-B25-V1D Firmware: through 1.10.0
- Pepperl-Fuchs Wcs Firmware: through 1.2.1
How to fix
Upgrade to a fixed version: Hilscher Ethernet/Ip Adapter Firmware 2.13.0.21. Check the vendor advisory for mitigations.
References
- https://cert.vde.com/en-us/advisories/vde-2021-007
- https://kb.hilscher.com/pages/viewpage.action?pageId=108969480
- https://cert.vde.com/en-us/advisories/vde-2021-007
- https://kb.hilscher.com/pages/viewpage.action?pageId=108969480
Get alerted when CVE-2021-20987 or the next vulnerability affects your stack