What’s Vulnerable › Vulnerabilities
CVE-2021-21014: Magento Commerce Arbitrary Folder Empty Could Lead To Arbitrary Code Execution
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-11 · updated 2026-06-17
- Weakness: CWE-434
Description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a file upload restriction bypass. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.
Affected products
- Adobe Magento Commerce: before 2.3.6; 2.3.6, 2.4.0, 2.4.0-p1, 2.4.1 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-08.html
- https://helpx.adobe.com/security/products/magento/apsb21-08.html
Get alerted when CVE-2021-21014 or the next vulnerability affects your stack