What’s Vulnerable › Vulnerabilities

CVE-2021-21016: Magento Commerce Unauthorized Data Modification Could Lead to Arbitrary Code Execution

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to OS command injection via the WebAPI. Successful exploitation could lead to remote code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21016 or the next vulnerability affects your stack