What’s Vulnerable › Vulnerabilities

CVE-2021-21018: Magnto Commerce Unauthorized Data Modification Could Lead To Arbitrary Code Execution

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to OS command injection via the scheduled operation module. Successful exploitation could lead to arbitrary code execution by an authenticated attacker. Access to the admin console is required for successful exploitation.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21018 or the next vulnerability affects your stack