What’s Vulnerable › Vulnerabilities
CVE-2021-21027: Magento Commerce Cross-Site Request Forgery (CSRF) Could Lead To Unauthorized Data Modification
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-11 · updated 2026-06-17
- Weakness: CWE-352
Description
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a cross-site request forgery (CSRF) vulnerability via the GraphQL API. Successful exploitation could lead to unauthorized modification of customer metadata by an unauthenticated attacker. Access to the admin console is not required for successful exploitation.
Affected products
- Adobe Magento Commerce: before 2.3.6; 2.3.6, 2.4.0, 2.4.0-p1, 2.4.1 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-08.html
- https://helpx.adobe.com/security/products/magento/apsb21-08.html
Get alerted when CVE-2021-21027 or the next vulnerability affects your stack