What’s Vulnerable › Vulnerabilities

CVE-2021-21030: Magento Commerce Stored Cross-site Scripting Could Lead To Arbitrary Javascript Execution

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are vulnerable to a stored cross-site scripting (XSS) in the customer address upload feature. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Exploitation of this issue requires user interaction.

Affected products

How to fix

Upgrade to a fixed version: Adobe Magento Commerce 2.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21030 or the next vulnerability affects your stack