What’s Vulnerable › Vulnerabilities
CVE-2021-21056: Adobe FrameMaker Out-of-Bounds Read Vulnerability Could Lead To Remote Code Execution
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-12 · updated 2026-06-17
- Weakness: CWE-125
Description
Adobe Framemaker version 2020.0.1 (and earlier) is affected by an Out-of-bounds Read vulnerability when parsing a specially crafted file. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Framemaker: before 2020.0.2 — fixed in 2020.0.2
How to fix
Upgrade to a fixed version: Adobe Framemaker 2020.0.2. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/framemaker/apsb21-14.html
- https://www.zerodayinitiative.com/advisories/ZDI-21-282/
- https://helpx.adobe.com/security/products/framemaker/apsb21-14.html
- https://www.zerodayinitiative.com/advisories/ZDI-21-282/
Get alerted when CVE-2021-21056 or the next vulnerability affects your stack