What’s Vulnerable › Vulnerabilities
CVE-2021-21070: Privilege Escalation Vulnerability in Adobe RoboHelp
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-19 · updated 2026-06-17
- Weakness: CWE-427
Description
Adobe Robohelp version 2020.0.3 (and earlier) is affected by an uncontrolled search path element vulnerability that could lead to privilege escalation. An attacker with admin permissions to write to the file system could leverage this vulnerability to escalate privileges.
Affected products
- Adobe RoboHelp RH2017.0.1 and earlier versions: before 2020.0.4 — fixed in 2020.0.4
How to fix
Upgrade to a fixed version: Adobe RoboHelp RH2017.0.1 and earlier versions 2020.0.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/robohelp/apsb21-20.html
- https://helpx.adobe.com/security/products/robohelp/apsb21-20.html
Get alerted when CVE-2021-21070 or the next vulnerability affects your stack