What’s Vulnerable › Vulnerabilities

CVE-2021-21084: Adobe Experience Manager stored cross-site scripting vulnerability in resource resolver factory could lead to arbitrary code execution

Description

AEM's Cloud Service offering, as well as versions 6.5.7.0 (and below), 6.4.8.3 (and below) and 6.3.3.8 (and below) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Affected products

How to fix

Upgrade to a fixed version: Adobe Experience Manager 6.4.8.4, 6.5.8.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-21084 or the next vulnerability affects your stack