What’s Vulnerable › Vulnerabilities
CVE-2021-21220: Google Chromium V8 Improper Input Validation Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 70.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-04-26 · updated 2026-06-17
- Weakness: CWE-787
Description
Insufficient validation of untrusted input in V8 in Google Chrome prior to 89.0.4389.128 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Affected products
- Fedoraproject Fedora: 32, 33, 34
- Google Chrome: before 89.0.4389.128 — fixed in 89.0.4389.128
How to fix
Upgrade to a fixed version: Google Chrome 89.0.4389.128. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162437/Google-Chrome-XOR-Typer-Out-Of-Bounds-Access-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/176210/Chrome-V8-JIT-XOR-Arbitrary-Code-Execution.html
- https://chromereleases.googleblog.com/2021/04/stable-channel-update-for-desktop.html
- https://crbug.com/1196683
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EAJ42L4JFPBJATCZ7MOZQTUDGV4OEHHG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U3GZ42MYPGD35V652ZPVPYYS7A7LVXVY/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VUZBGKGVZADNA3I24NVG7HAYYUTOSN5A/
- https://security.gentoo.org/glsa/202104-08
- http://packetstormsecurity.com/files/162437/Google-Chrome-XOR-Typer-Out-Of-Bounds-Access-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/176210/Chrome-V8-JIT-XOR-Arbitrary-Code-Execution.html
- https://chromereleases.googleblog.com/2021/04/stable-channel-update-for-desktop.html
- https://crbug.com/1196683
Get alerted when CVE-2021-21220 or the next vulnerability affects your stack