What’s Vulnerable › Vulnerabilities
CVE-2021-21242: Pre-Auth Unsafe Deserialization on AttachmentUploadServet
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 74.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-74
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, there is a critical vulnerability which can lead to pre-auth remote code execution. AttachmentUploadServlet deserializes untrusted data from the `Attachment-Support` header. This Servlet does not enforce any authentication or authorization checks. This issue may lead to pre-auth remote code execution. This issue was fixed in 4.0.3 by removing AttachmentUploadServlet and not using deserialization
Affected products
- theonedev onedev: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: theonedev onedev 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8
- https://github.com/theonedev/onedev/commit/f864053176c08f59ef2d97fea192ceca46a4d9be
- https://github.com/theonedev/onedev/security/advisories/GHSA-5q3q-f373-2jv8
Get alerted when CVE-2021-21242 or the next vulnerability affects your stack