What’s Vulnerable › Vulnerabilities
CVE-2021-21243: Pre-Auth Unsafe Deserialization on KubernetesResource
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 54.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-74
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, a Kubernetes REST endpoint exposes two methods that deserialize untrusted data from the request body. These endpoints do not enforce any authentication or authorization checks. This issue may lead to pre-auth RCE. This issue was fixed in 4.0.3 by not using deserialization at KubernetesResource side.
Affected products
- theonedev onedev: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: theonedev onedev 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/theonedev/onedev/commit/9637fc8fa461c5777282a0021c3deb1e7a48f137
- https://github.com/theonedev/onedev/security/advisories/GHSA-9mmq-fm8c-q4fv
- https://github.com/theonedev/onedev/commit/9637fc8fa461c5777282a0021c3deb1e7a48f137
- https://github.com/theonedev/onedev/security/advisories/GHSA-9mmq-fm8c-q4fv
Get alerted when CVE-2021-21243 or the next vulnerability affects your stack