What’s Vulnerable › Vulnerabilities
CVE-2021-21244: Pre-Auth SSTI via Bean validation message tampering
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-74
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, There is a vulnerability that enabled pre-auth server side template injection via Bean validation message tampering. Full details in the reference GHSA. This issue was fixed in 4.0.3 by disabling validation interpolation completely.
Affected products
- theonedev onedev: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: theonedev onedev 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/theonedev/onedev/commit/4f5dc6fb9e50f2c41c4929b0d8c5824b2cca3d65
- https://github.com/theonedev/onedev/security/advisories/GHSA-vm26-xg39-cfj4
- https://github.com/theonedev/onedev/commit/4f5dc6fb9e50f2c41c4929b0d8c5824b2cca3d65
- https://github.com/theonedev/onedev/security/advisories/GHSA-vm26-xg39-cfj4
Get alerted when CVE-2021-21244 or the next vulnerability affects your stack