What’s Vulnerable › Vulnerabilities
CVE-2021-21248: Post-Auth Arbitrary Code execution via Groovy script injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-74
Description
OneDev is an all-in-one devops platform. In OneDev before version 4.0.3, there is a critical vulnerability involving the build endpoint parameters. InputSpec is used to define parameters of a Build spec. It does so by using dynamically generated Groovy classes. A user able to control job parameters can run arbitrary code on OneDev's server by injecting arbitrary Groovy code. The ultimate result is in the injection of a static constructor that will run arbitrary code. For a full example refer to the referenced GHSA. This issue was addressed in 4.0.3 by escaping special characters such as quote from user input.
Affected products
- theonedev onedev: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: theonedev onedev 4.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/theonedev/onedev/commit/39d95ab8122c5d9ed18e69dc024870cae08d2d60
- https://github.com/theonedev/onedev/security/advisories/GHSA-gwp4-5498-hv5f
- https://github.com/theonedev/onedev/commit/39d95ab8122c5d9ed18e69dc024870cae08d2d60
- https://github.com/theonedev/onedev/security/advisories/GHSA-gwp4-5498-hv5f
Get alerted when CVE-2021-21248 or the next vulnerability affects your stack