What’s Vulnerable › Vulnerabilities
CVE-2021-21252: Regular expression denial of service in jquery-validation
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-13 · updated 2026-06-17
- Weakness: CWE-400
Description
The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
Affected products
- jquery-validation: before 1.19.3 — fixed in 1.19.3
- NetApp SnapCenter: all versions
How to fix
Upgrade to a fixed version: jquery-validation 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
- https://github.com/jquery-validation/jquery-validation/pull/2371
- https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- https://security.netapp.com/advisory/ntap-20210219-0005/
- https://www.npmjs.com/package/jquery-validation
- https://github.com/jquery-validation/jquery-validation/commit/5d8f29eef363d043a8fec4eb86d42cadb5fa5f7d
- https://github.com/jquery-validation/jquery-validation/pull/2371
- https://github.com/jquery-validation/jquery-validation/security/advisories/GHSA-jxwx-85vp-gvwm
- https://lists.debian.org/debian-lts-announce/2023/08/msg00040.html
- https://security.netapp.com/advisory/ntap-20210219-0005/
- https://www.npmjs.com/package/jquery-validation
Get alerted when CVE-2021-21252 or the next vulnerability affects your stack