What’s Vulnerable › Vulnerabilities
CVE-2021-21258: XSS injection in ajax/kanban
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI from version 9.5.0 and before version 9.5.4, there is a cross-site scripting injection vulnerability when using ajax/kanban.php. This is fixed in version 9.5.4.
Affected products
- glpi-project glpi: from 9.5.0 before 9.5.4 — fixed in 9.5.4
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15
- https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx
- https://github.com/glpi-project/glpi/commit/e7802fc051696de1f76108ea8dc3bd4e2c880f15
- https://github.com/glpi-project/glpi/security/advisories/GHSA-j4xj-4qmc-mmmx
Get alerted when CVE-2021-21258 or the next vulnerability affects your stack